Red Dead Redemption 2 - Benötigt die Steam-Version den Rockstar Games Launcher?

Guten Abend Gast. Schön, dass Du hereinschaust! Einen angenehmen Aufenthalt wünscht das CompiWare-Team.
  • Ich schaffe es unter Linux leider nicht, das Spiel "Red Dead Redemption 2" im Rockstar Games Launcher zu spielen. Den Rockstar Games Launcher habe ich in Lutris installiert. Starte ich den Launcher, habe ich darin das Spiel, welches ich bereits geladen und installiert habe. Leider startet das Spiel jedoch nicht. Es poppt ein kleines schwarzes Fenster mit einem Ladebalken auf und dann lande ich wieder auf dem Desktop. Es macht keinen Unterschied, ob ich Wine, Proton oder einen anderen Starter wähle.


    Im Internet habe ich gelesen, dass das wohl ein generelles Problem sein soll. Jemand hat dann geschrieben, dass er sich die Steam-Version vom Spiel gekauft hat und es nun darüber spielt.


    Meine Frage ist nun, ob zusätzlich zu Steam auch der Rockstar Games Launcher installiert und gestartet werden muss? Oder muss man sich einfach nur bei Rockstar einloggen, um das Spiel zu spielen?

  • Zur hilfreichsten Antwort springen
  • Also die Steam-Version benötigt den bis dato definitiv. Deshalb werde ich mir RDR2 auch niemals nicht auf keinen Fall kaufen, solange dieser R* -Dreck nicht entfernt wurde. :nono:

    Im Steam-Forum sind da auch viele unzufriedene Nutzer, die das nicht toll finden. :huh:

    • Hilfreichste Antwort

    Ja, die Steam-Version hat den RGL - und Social Club. Laut ProtonDB läuft die Steam-Version. :/


    ---

    Starte den RGL mal im Terminal. I.d.R. wird eine Fehlermeldung beim Absturz angezeigt, was immer ganz praktisch ist. Glaub, bei Lutris kann man einstellen, dass die App im Terminal ausgeführt werden soll.

    Einmal editiert, zuletzt von Zyankali ()

  • PoooMukkel Probiere mal bitte den Fix, den ich dir per PN geschickt habe. Damit sollte der Rockstar-Launcher umgangen werden.


    Ganz einfach entpacken und alle Dateien im Unterordner „files“ in dein Spielverzeichnis (wo RDR2.exe ist) kopieren und alles überschreiben (RDR2.exe vorher kurz sichern, wenn du willst). Beim Installieren hast du wahrscheinlich den Ordner selbst gewählt, denke ich. Ansonsten würde ich z. B. mit FSearch nach der Datei suchen, wenn du ihn nicht findest.

    Danach einfach Steam öffnen und die Datei RDR2.exe aus deinem Spielverzeichnis als Steam-fremdes Spiel hinzufügen und dann darüber starten (ohne Lutris oder den Rockstar-Launcher offen zu haben).


    Wäre schön, wenn du deine Fortschritte hier teilen könntest. Ich hätte auch Bock auf das Spiel, werde es mir vielleicht mal kaufen und wüsste gerne, ob die billigere Rockstar-Version auch läuft.

  • Es klappt leider auch mit dem Fix nicht. Ich habe den Fix eingespielt und vorhandene Dateien überschrieben. Dann habe ich die EXE in Steam eingebunden. Wenn ich versuche, das Spiel zu starten, dann ändert sich für ein paar Sekunden der Spielen-Button und dann springt er wieder zurück auf "Spielen".

  • Stelle mal in den Einstellungen des Spiels (Rechtsklick bei Steam -> Eigenschaften) unter Kompatibilität auf Proton Experimental um:



    Wenn das nichts bring, dann zusätzlich bei Allgemein das Steam-Overlay deaktivieren.


    Ergänzung, falls es dann immer noch nicht geht: Startparameter in Steam bei Allgemein setzen:

    Code
    WINEDLLOVERRIDES=vulkan-1=n,b

    Einmal editiert, zuletzt von Berny23 ()

  • Proton Experimental ist bei mir in Steam für alles aktiviert. Das mit dem Overlay probiere ich aus.


    EDIT: Auch das Deaktivieren des Overlays bringt keine Lösung. :/

    Einmal editiert, zuletzt von PoooMukkel ()

  • Ok, dann wird es sogar einfacher. Entferne mal alle Startparameter und sonstige Einstellungen von deinem Steam-fremden Spiel, dann setze diese Startparameter: PROTON_LOG=1 %command%


    Starte das Spiel danach, und sobald der Startbutton wieder „Spielen“ anzeigt, poste hier die aktuelle Logdatei: ~/steam-<irgendwelche_zahlen>.log

    Wahrscheinlich musst du die Endung in .txt umbenennen fürs Hochladen.

  • Hast du vielleicht doch die Flatpak-Version? Gib mal flatpak list ins Terminal ein und schau, ob da Steam dabei ist. Dann würde die Logdatei nämlich unter ~/.var/app/com.valvesoftware.Steam erscheinen.

  • Dann kontrolliere mal bei Steam, ob der Parameter richtig beim Spiel drinsteht:

    Code
    PROTON_LOG=1 %command%

    Am besten noch Proton Experimental dazu erzwingen in den Steam-Kompatibilitätseinstellungen des Spiels.


    Wenn es nichts hilft, schaue mal, ob funktionierende Steam-Spiele mit dem obigen Parameter überhaupt einen solchen Log ausspucken.


    Weitere Möglichkeit ist, den Pfad zur Logdatei explizit anzugeben als Parameter:

    Code
    PROTON_LOG_DIR=/home/<DeinNutzername>/rdr2-proton.log PROTON_LOG=1 %command%

    Oder in den Spieleinstellungen ältere Proton-Versionen erzwingen und testen.

    Einmal editiert, zuletzt von Berny23 ()